RIP Configuration

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# no auto-summary
R1(config-router)# network 10.0.0.0
R1(config-router)# network 172.16.0.0

The RIP 'network' command is classful, it will automatically convert to classful networks.

For example, even if you enter the command.

  • network 10.0.12.0, it will be converted to network 10.0.0.0 (a class A network).

There is no need to enter the network mask.

The network command

The network command tells the router to:

  • look for interfaces with an IP address that is in the specific range.

  • active RIP on the interfaces that fall in the range.

  • form adjacencies with connected RIP neighbors.

  • advertise the network prefix of the interface (NOT the prefix in the network command).

The OSPF and EIGRP network commands operate in the same way.

Example

R1(config-router)# network 10.0.0.0
  • Because the network command is classful, 10.0.0.0 is assumed to be 10.0.0.0/8.

  • R1 will look for any interfaces with an IP address that matches 10.0.0.0/8 (because it is /8 it only needs to match the first 8 bits).

  • 10.0.12.1 and 10.0.13.1 both match, so RIP is activated on G0/0 and G1/0.

  • R1 forms adjacencies with its neighbors R2 and R3.

  • R1 advertises 10.0.12.0/30 and 10.0.13.0/30 (NOT 10.0.0.0/8) to its RIP neighbors.

The network command doesn't tell the router which networks to advertise. It tells the route which interfaces to activate RIP on, and then the router will advertise the network prefix of those interfaces.

R1(config-router)# network 172.16.0.0
  • Because the network command is classful, 172.16.0.0 is assumed to be 172.16.0.0/16.

  • R1 will look for any interfaces with an IP address that matches 172.16.0.0/16.

  • 172.16.1.14 matches, so R1 will activate RIP on G2/0.

  • There are no RIP neighbors connected to G2/0, so no new adjacencies are formed.

  • R1 advertises 172.16.1.0/28 (NOT 172.16.0.0/16) to its RIP neighbors.

Although there are no RIP neighbors connected to G2/0, R1 will continuously send RIP advertisements out of G2/0. This is unnecessary traffic, so G2/0 should be configured as a passive interface.

R1(config-router)# passive-interface g2/0

The passive-interface command tells the router to stop sending RIP advertisements out of the specified interface (G2/0).

However, the router will continue to advertise the network prefix of the interface (172.16.1.0/28) to its RIP neighbors (R2, R3).

You should always use this command on interfaces which don't have any RIP neighbors.

EIGRP and OSPF both have the same passive interface functionality, using the same command.

Advertise a default routo into RIP

R1(config)# ip route 0.0.0.0 0.0.0.0 203.0.113.2

To propagate the default gateway we use:

R1(config-router)# default-information originate

Show ip protocols

Last updated